After machine reboots Bitbucket gets started by root, Why? Edited

Hi to all here in this forum:

I’m wondering maybe you can help me with this issue, I did an upgrade on our Bitbucket application (4.14.1 to 5.4.0 running in a RedHat Linux 6.9 Virtual Machine), and the upgrade was successful, (I was able to start and stop the application manually from within the application bin directory /path/to/the/5.4.0/bin -> ./start-bitucket.sh and ./stop-bitbucket.sh)

 

Then I created a startup script, which lives here -> /etc/init.d/bbtest_service, (bbtest_service is how I named the service) I tested the script several times by stopping and starting bitbucket thru command line (ran as “atlstash” who is Bitbucket’s designated user) as: service bbtest_service stop , service bbtest_service start;  The commands I just mentioned worked flawlessly, without a hitch, however as a final test I asked the whole Virtual Machine to be rebooted (because I'm not allowed to be root in the machine)

 

The VM was rebooted, and so I went into the server to test how operational it was, and when I tried to run from the command line either:  service bbtest_service stop or service bbtest_service start, the system would not let me.. for some reason on machine reboots root takes ownership of the process and starts bitbucket, also noticed that some files within Bitbucket’s home directory now are under root’s ownership, which I believe is causing all this problems, however the root of the problem is to determine why it does that.. maybe a setting within the operating system itself? Am at odds with this.

 Any help or ideas you might have are always welcome.

 

Thanks

Jesse

0 answers

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Friday in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

169 views 9 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you