Access the source code thhrough from Tab "Subversion Commit"

Hi all,

I have Jira and subversion integrated through from plugin atlassian-jira-subversion-plugin-0.10.7-distribution.zip

When i click in tab Subversion Commit and choose the revision 29260 the following error is showed.

Not Found

The requested URL /viewvc was not found on this server.

Please How can i configure it for that i have access to my source control (SVN) ?

Please could you help me ?

Thanks in Advance

BR

Fabio

4 answers

1 accepted

Ok, First make sure you can access viewvc outside of Jira. If you cannot do that, then work with the person responsible for your subversion/viewvc installation. If you can, then capture some of the urls as you click through the various tabs for changesets, diffs, etc that correspond to the items listed the Jira Subversion configuration screen. These urls becomes the model you need to use on the Jira Subversion configuration.

Get a subversion generic username/password account to be used by Jira or else use your own if you do not have one yet. This username/password all users will use, so it needs to work across all projects.

Here are my viewvc strings

View Format: http://<svnurl>:8080/viewvc/<svnroo>/${path}?pathrev=${rev}&view=markup

Changeset Format: http://<svnurl>:8080/viewvc/<svnroot>/?revision=${rev}&pathrev=${rev}&view=rev
File Added Format: http://<svnurl>:8080/viewvc/<svnroot>/${path}?pathrev=${rev}
File Modified Format: http://<svnurl>:8080/viewvc/<svnroot>/${path}?pathrev=${rev}&view=diff&r1=${rev}&r2=${rev-1}&diff_format=h
File Replaced Format: http://<svnurl>:8080/viewvc/<svnroot>/${path}/?revision=${rev}&view=markup
File Deleted Format: http://<svnurl>:8080/viewvc/<svnroot>/${path}?pathrev=${rev-1}

using your model strings above and

1) replace <svnrurl> with your url

2) replace or remove :8080 with your svn port or remove it if it is not needed.

3) replace <svnroot> with your svnroot as determined by your model urls. It is possible the <svnroot> does not exist either but highly unlikely.

4) Save your configuration changes

5) I do not remember if you need to just try an issue, logout/login again or restart Jira for your changes take affect, but you can tell by looking at the url property and seeing if the url string matches your updated string.

6) If it works great, if not then compare the new string to your models and make the necessary corrections.

In most cases, it is either your svnurl:port or svnroot that is not set correctly.

Hi Norman,

I can access viewvc outside Jira normally throught url : http://<svnurl>/viewvc

But when i tried to access the viewvc through JIra is showed the message below :

An Exception Has Occurred

The root "svn" is unknown. If you believe the value is correct, then please double-check your configuration.

HTTP Response Status

404 Not Found
 
 
My configurations in jira are these:
 

View Format: http://<svnurl>/viewvc${path}?root=svn&pathrev=${rev}&view=markup

Changeset Format: http://<svnurl>/viewvc?root=svn&revision=${rev}&pathrev=${rev}&view=rev
File Added Format: http://<svnurl>/viewvc/${path}?root=svn&pathrev=${rev}
File Modified Format: http://<svnurl>/viewvc/root=svn/${path}?pathrev=${rev}&view=diff&r1=${rev}&r2=${rev-1}&diff_format=h
File Replaced Format: http://<svnurl>/viewvc/root=svn/${path}/?revision=${rev}&view=markup
File Deleted Format: http://<svnurl>/viewvc/root=svn/${path}?pathrev=${rev-1}

I think that the problem is the root=svn.

Please what is neccessary put in the root?

Thanks in Advance

BR

Fabio

Please take the root parameter out and add after the viewvc string like I did in my string models to you. The root parameter does not seem to work. So if your root is svn then .../viewvc/svn/... You might find your actual root might be another level down like svn/project so ../viewvc/svn/project/?... Please note the final slash is important!

Hmm. Since the plugin has been upgraded since I needed to make this work, you might want to try a slash after viewvc with the root parameter. viewvc/&root...

If you use http access to the svn repository (not veiwvc) what is your path?

I also noticed your root parameter does not have ? in front of it on some of your model strings. The first parameter whatever it is must use a ? and the remaining parameters must use an & (html conventions) The substitution variable ${path} is not a parameter.

Which vendor are using for your subversion repository? It helps determine how Jira can access your repository such as websvn,viewvc or fisheye as examples.

Here is one answer involving websvn.

https://answers.atlassian.com/questions/21788/is-it-possible-to-integrate-jira-with-websvn?page=1#21821

Hi Norman,

We are using viewvc. Please how can we configurate it ?

Thanks in Advance

BR

Fabio

Oh, once things are working you can add other viewvc options on the command lines to setup your defautls if you want to change the initial display behaviors. You will need to read the viewvc documentation.

Hi Norman,

It worked :).

But How can i added the images to my index.

Where in my server should i include the images ?

Thanks in Advance

BR

Fabio

The GUI of the ViewVC is showed of this way:

I am not seeing any differences between these two images you uploaded. Also, my version of viewvc displays thing differently, so I am not sure what images you are refering to. This does not even look like viewvc to me. It feels more like a straight svn http call.

Can you provide some more details, so I can maybe figure out what is still broken? I am also curious if the root parameter worked for you or not.

What is one of the values for an image not showing and for one that is showing?

Hi Norman,

Follow below my configuration:

Changeset Format: http://svnurl/viewvc/reposname/?revision=${rev}&pathrev=${rev}&view=rev
File Added Format: http://svnurl/viewvc/reposname/${path}?pathrev=${rev}
File Modified Format: http://svnurl/viewvc/reposname/${path}?pathrev=${rev}&view=diff&r1=${rev}&r2=${rev-1}&diff_format=h
File Replaced Format: http://svnurl/viewvc/reposname/${path}/?revision=${rev}&view=markup
File Deleted Format: http://svnurl/viewvc/reposname/${path}?pathrev=${rev-1}

It worked , and the images are being shown too.

The problem images was the configuration in the viewvc.conf.

Thanks alot for your help.

BEst Regards

Fabio

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

636 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot