Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Above the 4 GB size limit further commits are rejected


We suddenly have the problem of exceeding 4gb in our repository.

We did not commit any large files: our last commits had only a few dozen source files, jsp, js etc.

We quickly went from 3.8gb (a few hours ago when we saw the warning) to 4.6gb. We do not understand what could have caused this increase.

We have run the commands twice as per your guide (git reset --hard and git push --force), repository is still blocked.

Can you please help us?

Here is the log in local of git count-objects -vH

count: 263
size: 1.03 MiB
in-pack: 612790
packs: 6
size-pack: 257.76 MiB
prune-packable: 77
garbage: 0
size-garbage: 0 bytes

Here the log of last command execution

user@devops:~/git/vino75$ git reset --hard @{u}^
Updating files: 100% (12766/12766), done.

HEAD is now at 124bc96e18 Merge branch 'master' into develop
user@devops:~/git/vino75$ git push --force

Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
remote: WARNING Repository size in Bitbucket is currently 4.6 GB
remote: Above the 4 GB size limit further commits are rejected
remote: Garbage collection will run automatically to help reduce the size of the repository. Wait until GC is complete to continue. This usually takes less than fifteen minutes but can take up to an hour. If you are still having issues after GC has finished, contact us at to increase your repository’s size limit.
remote: HINT Learn how to reduce repository size:
remote: Create pull request for develop:
+ b2d19fbcbb...124bc96e18 develop -> develop (forced update)

1 answer

1 accepted

0 votes
Answer accepted

UPDATE: Support solved this issue, running GC.

Erm, so does support have to do GC? How did you contact them exactly? I need the same done.

Hi Dimitry,

we switched to the paid plan and received support within a few hours

hmmm, I don't see why one needs to purchase another plan to get support on what should be a core function of hosting a GIT repo. If anything, it detracts from me purchasing anything from Atlassian. I mean, really, I need to get a plan to be able to contact support - to perform a function which I shouldn't have to contact support about? wtf?

My repo isn't even locked, I've recently cleaned it, and it still says that it's 2.9 GB out of 4 GB.

But the actual cleaned size is 320MB.

In our case, we urgently needed to get the problem solved quickly, which is why we changed the plan. I don't know if the same kind of support is also given with the free plan.

No worries - thanks for letting me know.

Like francesco3nd likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events