Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,198
Community Members
 
Community Events
177
Community Groups

API request failed with status 401 - Error occurring from 10-Mar-2022

Hi,

I am using bitbuket pipeline to run automation tests and have a step to upload the results at the end of the test execution using the pipe. This has worked fine for me since October 2021 and has stopped working today from 10-Mar-2022. My code snippet is as below:
- step:
script:
- apt-get update
- apt-get install zip -y
- zip EPPAutoTests/results_$BITBUCKET_BUILD_NUMBER.zip -r AutoTests/*.html
- pipe: atlassian/bitbucket-upload-file:0.3.2
variables:
BITBUCKET_USERNAME: $BITBUCKET_USERNAME
BITBUCKET_APP_PASSWORD: $BITBUCKET_APP_PASSWORD
FILENAME: AutoTests/results_$BITBUCKET_BUILD_NUMBER.zip

I have the above code working fine since October 2021, but when I executed it today I saw the below error in the pipeline:

INFO: Start uploading 1 files ['AutoTests/results_82.zip']...
✖ API request failed with status 401. Check your username and app password and try again.

My password is still the same and has not been changed for a long time. Also I tried entering the username and password again in the repository variable but I am still facing the issue today.

Can someone please help me with resolving this issue. Thanks.

 

1 answer

1 accepted

0 votes
Answer accepted

I was earlier using my bitbucket password which I now replace with a bitbucket app password. Works fine now.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events