Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,498
Community Members
 
Community Events
165
Community Groups

API Filter Doesn't Work

The API to access pipeline resources does not accept query parameters. 

For example, the following command returns all pipelines, not filtering at all. Note that the slash at the end of the URL (after "pipelines") is required for some reason; the API doesn't work without it. Note also that the ?sort= query parameter works.

curl -u {user}:{password} -X GET -H "Content-Type: application/json" https://api.bitbucket.org/2.0/repositories/{workspace}/{repo}/pipelines/?q=build_number%3D10

In contrast, the following call to the repositories/ path works, returning a single repo: 

curl -u {user}:{password} -X GET -H "Content-Type: application/json" https://api.bitbucket.org/2.0/repositories/{workspace}?q=name%3D%22example-repo%22

Can you please investigate this issue?

1 answer

1 accepted

0 votes
Answer accepted
Norbert C Atlassian Team Nov 24, 2021

Hi Adam,

Thank you for contacting Atlassian Community Support. I'm Norbert from Bitbucket Cloud Support, it's nice to meet you!

I'd like to inform you that indeed the following query doesn't work

curl -u {user}:{password} -X GET -H "Content-Type: application/json" https://api.bitbucket.org/2.0/repositories/{workspace}/{repo}/pipelines/?q=build_number%3D10

But as a workaround, when I've tried the following query, it showed me the details from my build:


curl -u user:password -X GET -H "Content-Type: application/json" https://api.bitbucket.org/2.0/repositories/workspace/repository/pipelines/buildnumber

Can I ask you to try to query the build using "pipelines/buildnumber" way and let me know if this workaround work for you?

I'm looking forward to hear from you.

Have a great week ahead!

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support Engineer

@Norbert C Thanks a lot for the reply. I'm trying this approach, but still can't figure out the right syntax. I've tried the following, which fail: 

  • pipelines/buildnumber/10 (404)
  • pipelines/buildnumber/10/ (extra slash at the end) (404)
  • pipelines/buildnumber?q=10 (400)
  • pipelines/buildnumber/?q=10 (404)
  • pipelines/buildnumber (400)
  • pipelines/buildnumber/ (404)
  • pipelines/buildnumber%3D10 (400)
  • pipelines/buildnumber%3D10/ (404)
  • pipelines?q=buildnumber%3D10 (404)
  • pipelines/?q=buildnumber%3D10 (returns all builds)
  • pipelines?buildnumber=10 (404)
  • pipelines/?buildnumber=10 (returns all builds)
Norbert C Atlassian Team Dec 01, 2021

Hi Adam,

Thank you for your reply.

Can I ask you to create a screenshot with the API call what you do, masking the private/confidential information, please? When I did the following API call, I've got an output from build #2. Once I have a screenshot, I might be able to see what went wrong with the API call.

apicall.png

I'm looking forward to hear from you, Adam.

Have a great day!

Best Regards,
Norbert 
Atlassian Bitbucket Cloud Support

Ok, by using just the integer build number, this works as intended now. 

Thanks a lot for your help. 

Norbert C Atlassian Team Dec 02, 2021

You're welcome Adam, we're always happy to help ;) 

Have a great weekend ahead!

Best Regards,

Norbert
Atlassian Bitbucket Cloud Support

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,242 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you