Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

404 Error Cloning to Visual Studio 2015

I have a new computer and am trying to clone a project I have in Bitbucket to my new machine using Visual Studio 2015. Under Team Explorer in "Local Git Repositories" I paste the repository URL, I copied from the repository home page, into the first entry box and the target folder in the next box. When I click the "CLONE" Button I get the following error ... 

"Error encountered while cloning the remote repository: Response status code does not indicate success: 404 (Not Found)."

I have tried a couple of different configurations of the clone URL including adding my password ...

https://gstenstrom@bitbucket.org/gstenstrom/phfr-application-framework

https://gstenstrom:password@bitbucket.org/gstenstrom/phfr-application-framework

Neither work and I continue to get the 404 error. I feel like I have done this before and all th eonline materials support the steps I am taking. I don't know what to try to get the repository to clone. 

Help!?

 

1 answer

One possible explanation and suggestion may be found here.

404 when cloning newly created Git Repository

Here is another that discusses issues of access.

VSO Build — Response status code does not indicate success: 404 (Not Found)

If neither these nor other web pages you find by web searching resolves your situation, I would suggest the work around of trying to clone outside of VS2015, which might also have the additional benefit of providing some diagnostic clues.

(As an aside, I also develop at times in VS2015.  However, I do most of my git operations either directly in a git command window or else via a separate git client, e.g. SourceTree for Windows.  I like using these rather than try to work through the limited git support inside VS2015.)

I've installed Git for Windows.  Then in a Git command window, I can use a git command directly to clone from the remote repository.  If you use Bitbucket, in the upper right corner of a repository page there is a Clone button.  Clicking there exposes a menu in the upper right that provides an appropriate git clone command.  The menu allows picking between cloning

by SSH (e.g. git clone git@bitbucket.org:myAccount/myRepo.git)
or
by HTTPS (e.g. git clone https://myUserName@bitbucket.org/myAccount/myRepo.git)

It might be that you have already tried this or something very nearly like it.  If direct calls to git also fail, then that provides the clue that the issue may not be with VS2015 after all.  (Maybe an access or naming issue, or a problem with an old version of git that is incompatible.)  If git on its own hits the problem, one could experiment and test just from the git command line and leave VS out of it for now.

OTOH, if using git directly to clone is successful, then the problem is something unique to your VS, such as in its settings.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,892 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you