Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,508
Community Members
 
Community Events
176
Community Groups

2FA not working

Edited

I've tried 3 times already, requesting recovery, waiting 24 hours, disabling 2FA on my Atlassian account, writing down the recovery key, enabling it again, adding the QR to google authenticator, writing down the new recovery key.

Then I try to login to my bitbucket account, password accepted, twp-step verification required, 6 digits code from the authenticator on the verification page is deemed invalid, recovery key is also deemed invalid.

yet there is no way of contacting a human for help, I wonder if there is any tbh. they seem pretty much focused on destroying the products Atlassian acquires. I really need to start pushing my employer harder to move to gitlab

update: I disabled 2FA again, deleted cookies and all site data on the browser, yet bitbucket still asks for a verification code. also when trying to login via google's oauth2. It's hard to imagine how messed up their internal systems are. 

1 answer

1 accepted

0 votes
Answer accepted
Ben Atlassian Team Jan 24, 2023

Hey Amery,

I'm sorry to hear that you are having issues gaining access to your account. My name is Ben and I am from the Bitbucket Cloud support team, I will be assisting you further. 

To explain the login process - before logging in to Bitbucket Cloud, you must first authenticate with your Atlassian Account (as AA is tied to Bitbucket Cloud workspaces). I have checked your Atlassian Account and can see that MFA is disabled, so, therefore, the 2FA likely exists at the Bitbucket Cloud level.

I have checked the Bitbucket Cloud workspace tied to your email and can see that 2FA is enabled here, so this confirms my suspicions. I have expedited a 2FA recovery email to your registered email address, I have checked our SMTP logs and can see that this email was successfully received by your mail server - so should be in your inbox now.

Please follow the instructions within the email, this should allow you to disable 2FA on your account. Once disabled, try to login again.

Once you are ready to re-enable 2FA, I would suggest clearing your Bitbucket Cloud account from your 2FA app and attempting to enable it again (refer to "Use two-step verification" subheading:
https://support.atlassian.com/bitbucket-cloud/docs/enable-two-step-verification/

Please let me know how this goes and reach out if any issues.

Cheers!

- Ben (Bitbucket Cloud Support)

Thank you, that worked and 2FA re-enabled successfully.

It's worth mentioning that when the bitbucket 2FA authentication failed I was always directed to resetting the atlassian account. dealing with the bitbucket account directly was never allowed until you sent that email with the magic link.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events