Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

pipelines are failing suddenly, it was working perfectly before[FIXED]

Russell Balahadia April 21, 2021

Error message received:

rpc error: code = NotFound desc = failed to pull and unpack image "docker.io/library/python:3.5.1": failed to unpack image on snapshotter overlayfs: failed to extract layer sha256:4dcab49015d47e8f300ec33400a02cebc7b54cadd09c37e49eccbc655279da90: failed to get reader from content store: content digest sha256:51f5c6a04d83efd2d45c5fd59537218924bc46705e3de6ffc8bc07b51481610b: not found

 

issue started today.

anyone having the same issue?

2 comments

Gurel Kaynak April 21, 2021

Having the same issue here... Cannot deploy anything.

Russell Balahadia April 21, 2021

Hi Gurel,

what image were you using for your pipeline?

Gurel Kaynak April 21, 2021

Hi Russell, 

Our main image is: 

image: python:3.5.1

 For some steps we use 

image: kramos/alpine-zip

Which works fine. 

Russell Balahadia April 21, 2021

yep same, looks like python 3.5.1 is already deprecated? 

I tried to change our image from python to atlassian/default-image:2 it worked.

however, I don't know which image you should use on your case. 

Gurel Kaynak April 21, 2021
image: python:3.7.2

Fixed it. Had no idea python 3.5.1 was going to be deprecated and removed. 

Like # people like this
Frank Gwosdz
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 22, 2021

I have the same issue, but for image "docker.io/library/gcc:6.1

Also suddenly happended since yesterday.

Any solutions? Thank you in advance.

Russell Balahadia April 23, 2021

try using a much later version than 6.1

Comment

Log in or Sign up to comment
TAGS
AUG Leaders

Atlassian Community Events