Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Visual Studio 2012 getting "libgit2.Category=Net An error occurred while sending request" error


I know VS2012 is old, but it has been working without issues for more than six months.

Since last Friday, when I tried to commit changes to the server, I would get a 'libgit2.Category=Net An error occurred while sending request' error... 

I tested in two different network environment, also on two different computers (one that I've been using for 6+months, one that was freshly installed).. All combinations get me this error..

I even tried to clone a repo to local, and got the same error..


Has anybody had similar issues?



1 comment

If anyone else has this problem, you can force earlier versions of VS to use TLS1.2 by setting the machine-wide keys described in this VS Developer Community post:


Log in or Sign up to comment
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,972 views 3 10
Read article

Atlassian Community Events