Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,574
Community Members
 
Community Events
176
Community Groups

Specifying the base URL for Bitbucket Server 5.5 Not changes the URL

Specifying the base URL for Bitbucket Server 5.5 Not changes the URL,

No matter what i'm doing i'm getting the original base URL of the server with port 7990.

 

2 comments

The base url in Atlassian applications tells the application where it is located. 

It does not tell your network where the application is - you'll need to change the network to route it to the new url.

I have another Atlassian env inside my company that i configured with earlier versions, all i had to do is to configure the Nginx and change the Base Url in the application.

For some reason with the 5.0 Version it's doesn't work.

Any idea how to route it so when i'm clicking 'Bitbucket' the URL will be a different one?

Nope, I'm sorry, but that is an incorrect description of what was done.

You can not change the location of a web service just by changing the location it uses for itself.  Your network needs to be updated to know where the new location is.

Imagine your Bitbucket server is your office.  Your mailing address is 123 Atlassian street, but you're going to move.  In your office, you have stationary that has the 123 Atlassian Street address on the header (this is the base url).  Just because you change the stationary header to a new address does not mean you've moved, or that the post office (the users trying to reach you) has that new address.  You need to tell them you've moved.

My best guess is that with your previous changes, you weren't changing the address, just the back-end settings.  This time, you've changed the address.

You need to get your network to route incoming connections to your proxy server so that it can pass them on to bitbucket.  The base url should be set to what the proxy is presenting on.

I am using a secured Nginx and an Unsecured Bitbucket,

I manged to resolve this issue by adding the next lines to my bitbucket.properties file (under the shared folder, if it's not there create it):

server.port=7990
server.secure=true
server.scheme=https
server.proxy-port=443
server.proxy-name=[my.proxy.name]
server.context-path=/bitbucket

 

Thanks Nic for your answers!

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events