Highlighted

Specifying the base URL for Bitbucket Server 5.5 Not changes the URL

Specifying the base URL for Bitbucket Server 5.5 Not changes the URL,

No matter what i'm doing i'm getting the original base URL of the server with port 7990.

 

2 comments

The base url in Atlassian applications tells the application where it is located. 

It does not tell your network where the application is - you'll need to change the network to route it to the new url.

I have another Atlassian env inside my company that i configured with earlier versions, all i had to do is to configure the Nginx and change the Base Url in the application.

For some reason with the 5.0 Version it's doesn't work.

Any idea how to route it so when i'm clicking 'Bitbucket' the URL will be a different one?

Nope, I'm sorry, but that is an incorrect description of what was done.

You can not change the location of a web service just by changing the location it uses for itself.  Your network needs to be updated to know where the new location is.

Imagine your Bitbucket server is your office.  Your mailing address is 123 Atlassian street, but you're going to move.  In your office, you have stationary that has the 123 Atlassian Street address on the header (this is the base url).  Just because you change the stationary header to a new address does not mean you've moved, or that the post office (the users trying to reach you) has that new address.  You need to tell them you've moved.

My best guess is that with your previous changes, you weren't changing the address, just the back-end settings.  This time, you've changed the address.

You need to get your network to route incoming connections to your proxy server so that it can pass them on to bitbucket.  The base url should be set to what the proxy is presenting on.

I am using a secured Nginx and an Unsecured Bitbucket,

I manged to resolve this issue by adding the next lines to my bitbucket.properties file (under the shared folder, if it's not there create it):

server.port=7990
server.secure=true
server.scheme=https
server.proxy-port=443
server.proxy-name=[my.proxy.name]
server.context-path=/bitbucket

 

Thanks Nic for your answers!

Comment

Log in or Sign up to comment
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

429 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you