Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Slow pull, push and clone

Miguel Leitão
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 3, 2022

I have been experiencing some waiting time whenever I pull, push or clone any repository from Bitbucket. This happens for both HTTPS and SSH repositories, I've tested it on different computers, different networks, and already reinstalled git. Every local git command works normally as well as all these operations but with different platforms, such as GitHub. I have tried with and without an SSH key configured into my Bitbucket account but no changes were visible. Does anyone knows what might be causing this or a way to somehow debug this issue?

1 comment

Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 5, 2022

Hi Miguel,

Thank you for contacting Atlassian Community. My name is Norbert and I'm a Bitbucket Cloud Support Engineer, it's nice to meet you! Welcome to the Atlassian Community.

  • Can you let me know whether if you have this issue with a specific repository or with every repository? 
  • Can we ask you to try to clone our test repository? The link for that is "git clone https://bitbucket.org/mirror/git
  • Would it be possible for you to give us a verbose output from a clone event? This would help us understand why the cloning is slow (please mask/remove every confidential information from the log):

    GIT_TRACE_PACKET=1 GIT_TRACE=1 GIT_CURL_VERBOSE=1 git clone.... 

  • Do you have IPv6 enabled in your network? In case you do, temporarily can you try to disable it and let us know if that makes any difference?

Please let us know how it goes, Miguel, we're here to help.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

Walter Tavares
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 7, 2022

Disabling IPV6 worked for me!!!

Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 9, 2022

I'm glad to hear I was able to help @Walter Tavares 

What I would like to suggest for you is to try to troubleshoot your IPv6 connectivity.

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

Comment

Log in or Sign up to comment
TAGS
AUG Leaders

Atlassian Community Events