Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

[ISSUE]remote: Could not create socket to ping Stash: Connection refused

Not able to Push in to the Bitbucket

 

GD00519242@INBASDPC08424 MINGW64 ~/git/atlassian-project-repo (master)
$ git push
\Counting objects: 39, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (19/19), done.
Writing objects: 100% (39/39), 4.07 KiB | 0 bytes/s, done.
Total 39 (delta 3), reused 0 (delta 0)
remote: Could not create socket to ping Stash: Connection refused
To http://10.20.126.38:7990/scm/ap/atlassian-project-repo.git
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'http://GD00519242@10.20.126.38:7990/scm/ap/atlassian-project-repo.git'

 

pre-receive hook declined --> We dont have any hooks enabled in bitbucket.

 

Any pointers about this issues.

 

1 comment

I have been having the same issue and opened a ticket for it.  I did not get resolution from the ticket but in my case found at least a temporary solution.  I am running iptables on my server and have rules opening up the ports specified for the services listed.  When I stopped iptables, my pushes ran successfully.  When I ran netstat on the server I discovered it was listening on an additional port.  I added that port, 45453, to my allowed list in iptables and my pushes worked with iptables running.  I have not restarted bitbucket server yet to see if the additional port I added remains the same or if it will change with each restart.

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

881 views 16 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you