It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

Bitbucket data center clustering

I'm trying to run a minimal installation of Bitbucket Data Center but whatever I do, http://host:7990/admin/clustering shows no nodes (I have no load balancer as it is optional according to documentation):

clustering.png

Though I expected to see at least one.

When I try to run another node with "shared" directory shared on NFS, it starts bu then I see this error in the browser:

---------------------------------------------------------------------

A fatal error has occurred

The following problem occurred, which prevents Atlassian Bitbucket from starting:

  • Home directory '/home/username/atlassian/stashik/shared' is already locked by another running instance of Bitbucket.

    Please stop the other instance of Bitbucket and restart this instance.

    If you are absolutely certain that no other instance of Bitbucket is running, please remove the lock file '/home/username/atlassian/stashik/shared/.lock' and restart this instance.

---------------------------------------------------------------------

So the fact that the directory is shared prevents it from starting.

When I tried to specify the same Postgres database to the second node, it complained that the database is not empty (of course, it's not empty, it was initialized by the first node).

So I'm absolutely confused.

My bitbucket.properties files is:

 

#>*******************************************************
#> Migrated to database at jdbc:postgresql://IP1:5432/stashik
#> Updated on 2015-10-23T23:22:32.416+02:00
#>*******************************************************
jdbc.driver=org.postgresql.Driver
jdbc.url=jdbc:postgresql://IP1:5432/stashik
jdbc.user=postgres
jdbc.password=

# Use multicast to discover cluster nodes (recommended).
hazelcast.network.multicast=false

# If your network does not support multicast, you may uncomment the following lines and substitute
# the IP addresses of some or all of your cluster nodes. (Not all of the cluster nodes have to be
# listed here but at least one of them has to be active when a new node joins.) 
hazelcast.network.tcpip=true
hazelcast.network.tcpip.members=IP1:5701,IP2:5701

# The following should uniquely identify your cluster on the LAN. 
hazelcast.group.name=your-bitbucket-cluster
hazelcast.group.password=your-bitbucket-cluster

Where IP1 and IP2 are IP addresses of my 2 nodes. I tried both multicast and tcpip.

My setenv.sh file contains

JVM_SUPPORT_RECOMMENDED_ARGS="-Dcluster.node.name=bitbucket-1"

line.

The log file contains no errors.

What should I do to tell Bitbucket Server that my configuration should consist of multiple nodes?

3 comments

Can somebody help me to resolve this issue.

I have no load balancer as it is optional according to documentation.

Hmmm. Data centre-Load Balancer=BrokenInstallation. How are you supposed to use the multiple nodes without a LB?

A load balancer is an important part of the data centre architecture. You can use apache/haproxy as a software LB.

Regarding the error:

This should not happen in a valid datacentre install. Looks like an instance of bitbucket server has locked your shared directory. If this is not the case.

You must ensure your shared file system server has the NFS lock service enabled . For example:

  • In some versions of Ubuntu Linux you must ensure that the portmap and dbus services are enabled for the NFS lockd to function.
  • In some versions of RedHat Enterprise Linux and CentOS, you must install the nfs-utils and nfs-utils-lib packages, and ensure the rpcbind and nfslock services are running.

Follow: https://confluence.atlassian.com/bitbucketserver/install-bitbucket-data-center-872139817.html

I know this is an old thread, but maybe it will help someone. Check the license (settings-licensing)! If the license is for Bitbucket Server, of course it cannot start.

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,573 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you