Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

git-ftp doesn't transfer newly created files

A script of mine creates new files (minifed js files) during the building process.

A test with - ls shows me the files are created, but git ftp doesn't transfer the newly created files (*.min.js). When i transfer the specific folder only the standard files (*.js) get transfered, which where there before the building process.

I tried it with the --all parameter for git ftp and declared the files as artifacts but nothing seems to work, any ideas?

1 answer

0 votes
mkleint Atlassian Team Oct 21, 2019

have you added and committed these new files into your git repository? I assume these newly created files during the build process will be unknown to git and as such git ftp will ignore them?


--all will in my understanding just upload all files known to git in current checkout (as opposed to the default behaviour of uploading just changed files?)

Thanks for your reply!

I didn't commit the newly created files to the repository. I just wanna create them before I deploy them to the FTP Server, like I do it with the vendor directory, just run composer install before I deploy it to FTP.

But I found a workaround:

In the pipelines.yml I create the min.js. files with my script, then I run git-ftp for all files, which pushes only the changed files to the FTP, and then I run atlassian/ftp-deploy only on the js folder, which pushes my newly created min.js files to the FTP.

It's a strange way, but it works :D

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Marketplace Apps & Integrations

Staying organized with Jira: best practices for a better project management

Project managers know this problem: A “mountain of work” lays in front of you, and you don’t know how and where to tackle them. Different to-dos lie ahead, but just one task after the other can be ha...

242 views 2 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you