Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

firebase-tools is out of date and doesn't support Node 14

Hi,

The recent versions of firebase-tools allow to use NodeJS 14 for functions. However, the current version does not support it. It would be great if it could be updated.

Thanks!

2 answers

0 votes

Hi @jposuna ,

We've released a new version of firebase-deploy pipe.

Now it supports NodeJS v14 and has updated firebase-tools v9.4.0.

script:
  - pipe: atlassian/firebase-deploy:1.0.0
    variables:
      KEY_FILE: $KEY_FILE
      PROJECT_ID: 'myAwesomeProject'
      MESSAGE: 'Deploying myAwesomeProject'
      EXTRA_ARGS: '--only functions'


It would be nice if you provide us with you feedback about the firebase-deploy pipe.

Cheers,
Oleksandr

0 votes

Hi @jposuna ,

Thank you for your request!

We'll investigate a support for NodeJS 14 and notify you.

 

Cheers,
Oleksandr

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍂📹 Apptoberfest demo contest roundup: vote for your favorite demos!

Hi Community! The submissions are in (and listed below) for the 🍻🍂Apptoberfest🍂🍻 Demo Competition and it’s time for you to place your votes for the best: Analytics & reporting app demo ...

261 views 7 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you