Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

atlassian/ftp-deploy:0.1.0 uploads to Build folder on remote Edited

I have a fairly simple PHP website's code sitting in a Mercurial repository.

 

Recently, this required a small change, and I tried to set up pipelines to help make the deployment part easier.  Unfortunately the web hosting company only supports FTP access to upload website content (long story; TLDR my client insists on using this web host).  So naturally I tried using atlassian/ftp-deploy:0.1.0, as that seems to be by far the simplest option.

 

Unfortunately that seems to be broken, as it uploads the website contents to /publich_html/build, and not to /public_html/ like I specified in `REMOTE_PATH`.

 

Here is my pipeline configuration:

pipelines:
  default:
    - step: 
        name: Deploy to webhost
        script:
        - pipe: atlassian/ftp-deploy:0.1.0
          variables:
            USER: $USERNAME
            PASSWORD: $PASSWORD
            SERVER: $FTPURL
            REMOTE_PATH: '/public_html/'
            # LOCAL_PATH: '<string>' # Optional
            # DEBUG: '<boolean>' # Optional

 

Why is it creating and uploading to a subdirectory? Can I make it upload to public_html instead?

 

I came across this similar question: https://community.atlassian.com/t5/Bitbucket-Pipelines-questions/SFTP-deploy-pipe-creates-build-folder-on-remote-and-fails-after/qaq-p/1053378

Unfortunately that answer (use git ftp) does not work for me, as this is a mercurial repo.

 

1 answer

1 accepted

3 votes
Answer accepted

Hi @Johan Pretorius . The ftp-deploy pipe is a bit different from the sftp-deploy. Basically, if you add a trailing slash to a REMOTE_PATH, the pipe uploads a base directory as well. If you only want to mirror the contents of the directory, you should remove the trailing slash from the REMOTE_PATH:

 REMOTE_PATH: '/public_html'

Thank you!  While I find this system quite counterintuitive, your suggestion worked for me.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

717 views 15 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you