Hello,
in my pipeline I'm loggin into my cloud foundry account with:
cf login -a ${CF_API} -u ${CF_USERNAME} -p ${CF_PASSWORD} -o "MyOrgName" -s ${SPACE}(the variables are taken from the BitBucket variables)
The login itself works, but sometimes it seems that I loose the session because I get an error from the client when I execute cf push:
<span>Not logged in. Use 'cf login' to log in.<br></span>
This happens sometimes even right after I have executed the cf login command. I have that issue quite some time with several versions of the Cloud Foundry CLI therefore I have implemented a script which checks if a cf command fails and then logs in again, but even the check if the log was successful sometimes fails with the mentioned error message even if it shows in the logs that it was successful. At the moment I'm using version 6.41.0 of the Cloud Foundry CLI. I don't have that issue on my local system, never had, it seems to appear only in my pipeline script.
Does anyone have similar issues with other clients or does anyone have the same issues?
Should I login differently within a pipeline or do I miss something else?
Any help is appreciated.
Regards,
Fabian