Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Server error: Unknown server error on fetching logs for bitbucket pipeline.

I am getting this error when fetching one of my step's log. Which looks like an internal server error.

{
"error": {
"message": "Not found",
"data": {
"arguments": {
"uuid": "the-uuid-of-step"
},
"key": "result-service.log.not-found"
},
"detail": "retrofit2.adapter.rxjava.HttpException: HTTP 404 Not Found (command LOG_SERVICE_GET_LOG_STREAM, error key='log-service.file.not-found')"
}
}

 

1 answer

0 votes

Hi Rhitik,

Was there a traceId or requestId in the response payload that you can share?

Is this happening for just a single step, or several?

Thanks,

Phil

Hey Philip,

 

No there was no requestId or traceId in the response. I have shared the whole response  just leaving out the UUID.

 

I have just one step in the pipeline. But on other run of the pipelines I am able to get the logs successfully for the same step.

 

Thanks,

Rhitik

Thanks for the information rhitik.bhatt@rivetlabs.io.

Can I get you to open a support case here: https://support.atlassian.com/contact

I suspect there was an error uploading your logs, rather than downloading them. And we'd like to investigate what the root cause of this is, so it doesn't happen to you (or other users) again.

Please tell the Support Engineer to escalate this ticket to the dev team. Or alternatively, to ping @Graham Gatus or myself. (Link them to this ticket so they know I asked :) )

Thanks,

Phil

Hey Phil,

I investigated a bit further as to why the pipeline failed. Turns out that the Docker Hub Credentials were not present in the repository Variables and as a result there was an error on the build step which I think so is the reason why the logs were not pushed.

 

I will go ahead and open a support case since this is not the desired behaviour.

 

 

Thanks,

Rhitik

Was there any error message on the Pipeline Result? (It should be under the 'Failed' or 'Error' icon) Otherwise, we should readd it. As that used to be in the UI to surface these types on these issues. :)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

788 views 15 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you