Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Previously working pipeline bash now fails Edited

I'm having a strange issue with Bitbucket Pipelines, where a previously working pipeline now fails without warning.

In this particular case I am, using bash, incrementing a variable of `0`.

(( VERSION_NUMBER_LIST[1]++ )); echo "${VERSION_NUMBER_LIST[0]}.${VERSION_NUMBER_LIST[1]} list version incremented";


What is especially confusing is that this worked fine before, and works in my local testing:


0.0 list version

(( VERSION_NUMBER_LIST[1]++ )); echo "${VERSION_NUMBER_LIST[0]}.${VERSION_NUMBER_LIST[1]} list version incremented";
0.1 list version incremented


Has anyone else encountered this strange error, or have any idea how to resolve.

My pipeline repeatedly fails due to this.


I'm using an Alpine 3.11 as my Docker image.

1 answer

1 accepted

0 votes
Answer accepted

Fixed it with:

VERSION_NUMBER_LIST[1]=$((VERSION_NUMBER_LIST[1]+1)); echo "${VERSION_NUMBER_LIST[0]}.${VERSION_NUMBER_LIST[1]} list version incremented";
0.1 list version incremented


Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

3,886 views 68 21
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you