Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Pipeline cache downloading and extracting but not loading

So I cache a the folder "_bin" under the cache named "bin." 

 

After running a pipeline that creates the cache, I run my tests. 

In the build setup, the output reads: 

 

pipeline output help.PNG

 

 

 

This cache holds a compiler needed for testing, however when using said compiler, an error is thrown.

I have tried running the pipeline that creates the cache in the same pipeline that tests it, and that works fine, so it is not a faulty path or any other error that I know of. 

 

My .yml where it causes the error:

pipelne cache help.PNG

 

The install_gcc_bitbucket.sh script sets the path then tests to see if the compiler exists, and this is where it is failing. 

 

In another post, I saw someone say that the output should download, extract, THEN load; which mine does not. So I believe this is the error. 

Can anyone confirm this?

 

Either way, what could be some possible issues here? Thanks. 

 

1 answer

1 accepted

0 votes
Answer accepted

So I found the issue, which is pretty strange. I am using a custom cache and it should by default be in the root dir.

But I came across a fix that I don't think should have worked.

The fix: 

 

cache fix.PNG

For whatever reason, adding the $BITBUCKET_CLONE_DIR variable which specifies the root dir fixed the issue.

 

This means that they could be lying about custom caches, and that it doesn't really start at the root dir unless you specifically tell it to. 

 

Either way my gcc script can find the cache fine and do its thing now. yay.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

2,112 views 43 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you