It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Download private repository in a docker container in bitbucket pipelines Edited

I am running the following script in a pipeline:

script:
- ...
- docker run --rm -v $BITBUCKET_CLONE_DIR/app-src:/var/www my_image:latest composer install

 As you can see it runs a `composer install`. This works. But the composer.json also contains some private repositories. To be able to install these private repositories. The container inside bitbucket pipelines needs to have access to ssh in the container.

I have tried a lot things, but constantly it can't get the ssh settings of the host in the container.

Does anyone have a clue on how to fix this?

The message I have is "Host Key Verification failed". But after that it will probably complain about credentials.

I have tried to run ssh-agent inside bitbucket pipelines. But doing:

script:
- ...
- eval "$(ssh-agent -a $BITBUCKET_CLONE_DIR/agent.sock -s)"
- ssh-add

doesn't work, because it probably can't read the  ~/.ssh dir.

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

What We Learned When We Researched Open Source Vulnerabilities in 7 Popular Coding Languages

...hey are a part of us, shaping how we interact with the world around us. The same holds true for programming languages when we think about how different kinds of vulnerabilities raise their heads in t...

1,027 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you