Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Connecting to remote repo during Roots Trellis deploy in Bitbucket Pipeline Edited

 

I am having issues with doing deploys (from the Roots Trellis deploy script) from a Bitbucket Pipeline to a staging/prod server. The problem specifically is:

TASK [deploy : Clone project files] ********************************************
System info:
  Ansible 2.8.8; Linux
  Trellis Head
---------------------------------------------------
fatal: [46.101.65.29]: FAILED! => {"censored": "the output has been hidden due to the fact that 'no_log: true' was specified for this result", "changed": false}
...ignoring
TASK [deploy : Remove untracked files from project folder] *********************
ok: [46.101.65.29]
TASK [deploy : Failed connection to remote repo] *******************************
System info:
  Ansible 2.8.8; Linux
  Trellis Head
---------------------------------------------------
Git repo git@bitbucket.org:clayton93/trellis.git cannot be accessed. Please
verify the repository exists and you have SSH forwarding set up correctly.
More info:
> https://roots.io/trellis/docs/deploys/#ssh-keys
> https://roots.io/trellis/docs/ssh-keys/#cloning-remote-repo-using-ssh-
agent-forwarding
fatal: [46.101.65.29]: FAILED! => {"changed": false}

It seems to be having trouble cloning the repo. The repo is the same (private) repo the Pipeline is running in. I have added the pipeline’s SSH key to the repo’s Access Keys which I hoped would solve it.

My pipeline config is:

pipelines:
  branches:
    master:
      - step:
          name: First Step
          image: misterio92/ci-php-node:3.0
          caches:
            - composer-bedrock
            - composer-sage
            - node-sage
          script:
            - cd $BITBUCKET_CLONE_DIR/trellis && echo $VAULT_PASS > .vault_pass
            - apt-get update -qy
            - apt-get install -y python-dev python-pip
            - chmod 700 /opt/atlassian/pipelines/agent/build
            - chmod 700 /opt/atlassian/pipelines/agent/build/trellis
            - cd $BITBUCKET_CLONE_DIR/trellis && pip install -r requirements.txt
            - cd $BITBUCKET_CLONE_DIR/trellis && ansible-galaxy install -r galaxy.yml
            - cd $BITBUCKET_CLONE_DIR/trellis && ./bin/deploy.sh production trellis.wearefx.uk --vault-password-file .vault_pass --inventory hosts/production

 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

902 views 18 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you