Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,558,788
Community Members
 
Community Events
184
Community Groups

why is bamboo stop working?

midway through a deploy bamboo stalled out and stopped respondinging(the deploy was a very minor code change).

bamboo didnt respond for over an hour but was still showing in 'ps aux', didnt seem to be using excessive resources nor stalled.

restarted server, restarted bamboo, same result... will not respond to requests but starts without error and leaves nothing questionable in the logs.

upgraded bamboo, from 5.5 to 6 and now i get the following when trying to connect from the machine its running on...

wget https://localhost:8085
--2017-11-10 04:25:13--  https://localhost:8085/
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:8085... connected.
OpenSSL: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
Unable to establish SSL connection.

 

any ideas? help? anything? kind of bizarre for this to just break halfway through a deploy and never recover.

 

do i need to replace the ssl cert that bamboo is using? if so, where is that stored?

1 answer

0 votes
robhit
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Nov 10, 2017 • edited

can you check your tomcat connector settings (<bamboo-install>/conf/server.xml file) to see if you have are using the SSL parameters such as "scheme" 

 

You can compare it with the old bamboo server.xml file 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events