Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,226
Community Members
 
Community Events
176
Community Groups

using docker-compose in bamboo

Hi,

I need to run multiple docker containers at the same time and need to mount volumes to one of the containers and docker-compose.yml files are the best way to manage this. However, I am not sure how can I run docker-compose files in Bamboo as its not a capability. I am using Bamboo version 7.

Since docker is a capability I have tried using a docker-compose image in a Docker container in my Bamboo plan. I have two tasks in my Job so first one checks out the source code and the second task runs a shell script containing the command "docker-compose up". When bamboo downloads the docker-compose image and then runs the shell script it keeps running into an error message saying "Couldn't connect to Docker daemon at http+docker://localhost - is it running?" 

Does anyone have any idea on how to solve this issue?

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events