Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,304
Community Members
 
Community Events
168
Community Groups

the remote agent does not show up in theonline agent list

Hi,

 

I have followed the installation instruction to install bamboo remote agent.

everything goes as expected until the last step.

the agent log says the following in the log but it does not show up in the online agents.

2019-07-10 16:51:58,811 INFO [AgentRunnerThread] [QuartzScheduler] Scheduler scheduler_$_NON_CLUSTERED started.
2019-07-10 16:51:59,025 INFO [AgentRunnerThread] [RemoteAgent] ************************************************************************************************************************************************************
2019-07-10 16:51:59,025 INFO [AgentRunnerThread] [RemoteAgent] * *
2019-07-10 16:51:59,025 INFO [AgentRunnerThread] [RemoteAgent] * Bamboo agent 'ip-10-0-45-136' ready to receive builds.
2019-07-10 16:51:59,025 INFO [AgentRunnerThread] [RemoteAgent] * Remote Agent Home: /home/ubuntu/bamboo-agent-home
2019-07-10 16:51:59,025 INFO [AgentRunnerThread] [RemoteAgent] * Broker URL: failover:(tcp://XXX.YYYY.COM:54663?wireFormat.maxInactivityDuration=300000)?initialReconnectDelay=15000&maxReconnectAttempts=10
2019-07-10 16:51:59,025 INFO [AgentRunnerThread] [RemoteAgent] * *
2019-07-10 16:51:59,025 INFO [AgentRunnerThread] [RemoteAgent] ************************************************************************************************************************************************************
2019-07-10 16:56:59,182 INFO [0-BAM::ip-10-0-45-136::Agent:pool-3-thread-1] [BuildAgentControllerImpl] Agent -1 checking build queue for executables...
2019-07-10 17:00:04,301 INFO [remoteEventRebroadcasterMessageListenerContainer-1] [RemoteEventRebroadcasterMessageListener] ExecutableQueueUpdate: addToQueue, agents known to be affected: []
2019-07-10 17:01:59,194 INFO [0-BAM::ip-10-0-45-136::Agent:pool-3-thread-1] [BuildAgentControllerImpl] Agent -1 checking build queue for executables...

the only thing that appears on the online remote agent tab in the agents menu is a line of log as follows:

A remote agent is loading on ip-10-0-45-136 (10.0.45.136).

I have granted access to remote agent during setup of the agent.

 

My Bamboo server is on Windows.

My Bamboo remote agent is on Ubuntu 18 using OpenJDK 11.

 

I would be really grateful if somebody can help me.

Thank you very much in advance

 

1 answer

1 accepted

0 votes
Answer accepted

Hi @Amir

You should run the remote agent with a version supported in our Supported platforms - Atlassian Documentation. The latest supported version is OpenJDK 1.8.

The description you shared also happens when a remote agent is manually cloned (copying the folders and starting a new instance). This is because the GUID of the agent is the same. In this case, the agent comes up, but Bamboo is not able to see more than one agent.

My suggestion is:

  1. Change the JDK to the supported version
  2. If you cloned the agent, please install a new one

I hope that helps.

Thank you, I downgraded the OpenJDK to 1.8 and it worked

Hi @Amir

I'm glad it worked and you now have your remote agent available!
Have a great day! 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events