Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,027
Community Members
 
Community Events
168
Community Groups

"No such file or directory" when running simple command on linux bamboo agent. UPDATE - new question

Edited

I'll probably forget to include some details, so bear with me.

 

To demonstrate my problem I have created a simple plan. It's the sole purpose to verify a file exists by doing an "ls -ls <filename>". 

 

It fails. What am I doing wrong? I suspect ist has something to do with permissions on the build agent VM. 

 

On the build agent machine, a linux VM, I run the command

/usr/bin/ls -ls /home/bgillespie/ivy

total 8

0 drwxr-xr-x. 2 bamboo     bamboo      215 Feb 19 16:10 cache

4 -rwxrwxrwx. 1 bgillespie bgillespie 2602 Feb 19 15:43 ivyconf.xml

4 -rwxrwxrwx. 1 bgillespie bgillespie  218 Feb 18 13:40 ivy.properties

 

Output from the build log when I run the plan in bamboo:

...

simple	19-Feb-2020 17:13:20	Starting task 'see if ivyconf.xml found' of type 'com.atlassian.bamboo.plugins.scripttask:task.builder.command'
command	19-Feb-2020 17:13:20	Beginning to execute external process for build 'TEST - BRIAN_TEST - BUILD #1 (TEST-BRIANTEST-JOB1-1)'\n ... running command line: \n/usr/bin/ls -ls /users/bgillespie/ivy\n ... in: /home/bamboo/agent-2-home/xml-data/build-dir/TEST-BRIANTEST-JOB1
...
error	19-Feb-2020 17:13:20	/usr/bin/ls: cannot access /users/bgillespie/ivy: No such file or directory
simple	19-Feb-2020 17:13:20	Failing task since return code of [/usr/bin/ls -ls /users/bgillespie/ivy] was 2 while expected 0
simple	19-Feb-2020 17:13:20	Finished task 'see if ivyconf.xml found' with result: Failed

The directory itself is wide open permission wise

ls -lsd /home/bgillespie /home/bgillespie/ivy

0 drwxrwxrwx. 11 bgillespie bgillespie 280 Feb 19 15:55 /home/bgillespie/

0 drwxrwxrwx. 3 bgillespie bgillespie 77 Feb 19 16:10 /home/bgillespie/ivy

 

thanks,

 

1 answer

1 accepted

As a test I got a new VM spun up with same OS, installed the needed software including a new bamboo client and now my problem is gone. Apparently some kind of a problem with the build agent I was using.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events