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Why am I not allowed to upgrade to a Bamboo version without security problems?

Hello!

While trying to upgrade from Bamboo 6.0.3 to 6.1.6 to close the security hole from recent alert, Bamboo 6.1.6 tells me at startup:

 

Bamboo bootstrap failed: Unable to run pre-bootstrap upgrade tasks as your support period has ended. Please contact Atlassian Support at https://support.atlassian.com

 

What's wrong here?

 

--

 

Greetings

 

  Pete

1 answer

1 accepted

1 vote
Answer accepted
somethingblue
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Dec 13, 2017

Hi,

It sounds like a licensing issue and that is confirmed by the knowledge base article titled Unable to run pre-bootstrap upgrade tasks as your support period has ended:

Cause

An expired key is being loaded by Bamboo during startup.

Resolution

This error happens when a customer has got 2 licenses on their account but the one that already expired loaded into their Bamboo.

The property below on your <Bamboo_Home>/bamboo.cfg.xml contains the license that already expired:

<property name="license.string"> (valid license value here) </property>

 

Here are the steps to fix this:

  • Stop your Bamboo instance
  • Backup the bamboo.cfg.xml file somewhere else in your file system
  • Login to MyAtlassian
  • Retrieve the valid license key
  • Copy and paste the new license key on the property below, overwriting the one that expired:

    <property name="license.string"> (valid license value here) </property>
  • Restart your Bamboo instance

Try the steps listed in the knowledge base article and let us know if you're still running into this issue.

Cheers,

Branden

Thank you Branden!

 

Indeed bamboo.cfg.xml contained the former license key (or such). And it was not updated even when I started the former version of Bamboo, 6.0.3, and re-entered the recent key. Doing it with vi let Bamboo 6.1.6 launch. I'll try now to launch version 6.2.5.

 

--

 

Pete

somethingblue
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Dec 14, 2017

I'm glad we were able to find out what's causing the issue.  Let us know if you run into issues starting 6.2.5.

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