What kind of capability do I need in order to execute a bat file from bamboo remote agent

I have a bat file located in a remote agent running on windows server. I was trying to add a plan to execute that bat file from the bamboo dashboard.

I added a command in the taskes, but not sure what kind of executable I need to add into the agent capability in order to run this bat file.

1 answer

This widget could not be displayed.

Add a Script Task, and set the path there. No further configuration is needed.

I tried but got the following errors in the log. When I run the same bat file from the remote client directly, it is okay.

13-Dec-2011 12:57:19 Starting task 'Script' of type 'com.atlassian.bamboo.plugins.scripttask:task.builder.script'
13-Dec-2011 12:57:19
Beginning to execute external process for build 'Regression Testing - 2011-12 - Selenium - Default Job'
... running command line:
E:\test\bin\run-test.bat
... in: E:\bamboo-agent-home\RemoteAgentHome\xml-data\build-dir\REGRESSION201112-SELENIUM-JOB1
... using extra environment variables:
bamboo_fortify_auth_token=b07a63fa-cbdf-46b0-90df-274f0cb090fe
bamboo_fortify_home=/usr/local/Bamboo-Dependencies/fortify
bamboo_JBOSS_HOME=/usr/local/Bamboo-Dependencies/jboss
bamboo_fortify_url=https://fortify.test.aus.test.net/fortify
bamboo_JAVA_HOME=/usr/local/test/java
bamboo_qa_database=qadb
The system cannot find the path specified.
13-Dec-2011 12:57:19 java.lang.NoClassDefFoundError: org/python/util/jython
12:57:19 Caused by: java.lang.ClassNotFoundException: org.python.util.jython
13-Dec-2011 12:57:19 at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
13-Dec-2011 12:57:19 at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
13-Dec-2011 12:57:19 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
13-Dec-2011 12:57:19 at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
13-Dec-2011 12:57:19 at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
Could not find the main class: org.python.util.jython. Program will exit.
13-Dec-2011 12:57:19 Picked up JAVA_TOOL_OPTIONS: -agentlib:jvmhook
13-Dec-2011 12:57:19 Picked up _JAVA_OPTIONS: -Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~1\HP\QUICKT~1\bin\JAVA_S~1\classes;C:\PROGRA~1\HP\QUICKT~1\bin\JAVA_S~1\classes\jasmine.jar
13-Dec-2011 12:57:19 Exception in thread "main"

You need to add jython.jar to classpath in your batch file.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

207 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you