Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,527
Community Members
 
Community Events
168
Community Groups

Using newer versions of "system bundle" packages

I am writing a Bamboo plugin that needs org.atlassian.commons.configuration with version >= 1.5, but the system bundle only provides version 1.4-atlassian-1. If I embed commons-configuration with a compile scope, then I get various errors suggesting that the compiled-in version of the package (1.5) is loaded simultaneously with the Bamboo-supplied version (1.4). How should I handle this situation? I think excluding the 1.4 version would be fine, if possible, but I don't know how to exclude a package provided by the system bundle.

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events