Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Using newer versions of "system bundle" packages

I am writing a Bamboo plugin that needs org.atlassian.commons.configuration with version >= 1.5, but the system bundle only provides version 1.4-atlassian-1. If I embed commons-configuration with a compile scope, then I get various errors suggesting that the compiled-in version of the package (1.5) is loaded simultaneously with the Bamboo-supplied version (1.4). How should I handle this situation? I think excluding the 1.4 version would be fine, if possible, but I don't know how to exclude a package provided by the system bundle.

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bamboo

Bamboo Data Center 8.1 is now available

G’day Bamboo customers, Bamboo DC 8.1 is now available with it the following features and programs: SAML 2.0, OpenID Connect, and Crowd SSO In order to help admins with a simplified user manage...

200 views 0 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you