Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Two Issues After Install - Cannot Create File & Bamboo Service Terminated

Hello, 

I've recently installed the latest Bamboo trial however I've encountered the following two issues 

1.  Whenever I attempt to create a build/project/anything which creates a file on the server I encounter some for of the below message

Could not check if existing access key is valid: java.lang.RuntimeException: java.io.IOException: Could not create file: C:\Atlassian\Bamboo\temp\bamboo-ssh.41538fd5.bat

 I've tried Running the service as administrator but this didn't resolve it.

In regards to directory permissions, I cannot find anything which tells you what the folder permissions should be. 

 

2. When I attempt to start the installed Bamboo service, the following is logged to  the event viewer

The Atlassian Bamboo Bamboo service terminated with the following service-specific error: 
Incorrect function.

 

Can anyone point me in the right direction. I've googled for possible solutions and been unsuccessful so far. 

 

1 answer

0 votes
Jimmy Seddon Community Leader May 23, 2019

Hi @Thomas_Renshaw,

Welcome to the Community!

My first question is how are you able to get to the point of trying to create a build plan/project when issue number two is that you can't get the service to start?  Or is that the issue you are facing once you tried to switch to running the service as an admin user and the service won't start now?

While the event viewer doesn't show too much helpful information the Bamboo log files might be more helpful.

Are you able to take a look in the following location:

<Bamboo_Install_Directory>/logs - and take a look at the date time stamps around the time you tried to start the service and it failed for something that looks similar to: bamboo-stderr.2019-05-15.log

You can also look in <Bamboo_Home>/logs and see if it got far enough to create an atalssian-bamboo.log file and if there are any errors reported in there.

You could also look at this post here to see if any of the suggestions here help you, though I believe you have a different error than what was reported here: https://community.atlassian.com/t5/Questions/Installing-Bamboo-for-the-first-time-cannot-get-service-to-start/qaq-p/82747

I hope that helps get you started.

-James

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

223 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you