Trouble with Task "Artifact download"

Hi everyone,

I'm new to Bamboo and in the process of setting up my first deployment process.

So far I was able to set up everything propably folloing the instructions from the website. However now I kinda got stuck.

I saw a couple of similar postings but none of the possible solutions seem to work.

My first Job has three tasks so far, a source code checkout (works fine), Maven 3.x (works fine) and an Artifact download. The last one is where I'm running into issues.

My build process runs smoothly with the message "BUILD SUCCESS". Afterwards I get a message "Unable to download artifact Shared artifact: Shared artifact: [Artifact], pattern: [**/*.war] anchored at: [path/to/target]".

In my task I configured Location as "path/to/target" and copy pattern as "**/*.war" (without the quotes).

I checked the folder and my .war file is present. Artifacts tab in the build report shows my .war file as well, downloading it works, too.

Any help or clue is appreciated!

Bamboo version is 5.15.3 running on Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-71-generic x86_64)

2 answers

2 accepted

The Artifact Download task cannot download artifacts from the same build. You need to configure Artifact Dependencies instead.

Artifact Dependencies are for sharing between stages, Artifact Download task is for accross plans.

Hi,

thanks a lot for your for your answer, sorry somehow I was logged in with a wrong account last time.

Ok I guess there is some kind of a misunderstanding in my mind. I removed the Artifact Downloading task from my build plan and activated it in my Deployment project following Sharing artifacts from a build plan to a deployment environment in the Documentation.

When I run my plan seperately logs say the working directory is "/path/to/directory/xml-data/build-dir/job" and it builds my file into a subdirectory of that folder "/path/to/target/file.war". Everything works fine.

When I run my Deployment project, logs say my build working directory is "/path/to/directory/xml-data/build-dir/1474561-1605634". So I configured my shared artifacts location as "../job/path/to/target" while stil using the same Copy pattern "**/*.war".

The result I see in my logfile is "Unable to download artifact Shared artifact: [ARTIFACT], pattern: [**/*.war] anchored at: [../job/path/to/target]".

I feel kinda dumb, this has to be a basic mistake and I am not able to figure it out.

Thanks a lot again.

Hi @Florian Strodtmann I am also stuck at the same step. I have my build plan generate artifacts( a tar file) at "/usr/bamboo/bamboo-agent-home/agt1/xml-data/build-dir/PLAN-PS-JOB1/artifact/abc.tar". The build is successful.
But during the deployment plan  I see in my logfile is "Unable to download artifact Shared artifact: [ARTIFACT], pattern: [**/abc.tar] anchored at: [artifact/]". I am guessing that my path while sahring the artifact is messed up. Can you help me ?

Solved my problem, I just had a serious mix in my path definitions.

Thank you again!

this one said "Solved my problem". where can I find the fix description.

 thank you.

Andy

I have the same problem @Marcel Schwander what is the solution?

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,074 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot