Test scripts run in non-GUI mode on 64-bit bamboo remote agent

Hi Atlassian Bamboo Support,

We use Bamboo for Continuous Integration purpose. For testing the GUI of a business application, we have a tool called HP QuickTest Professional (QTP) whose tests run after the application code is built using Bamboo.

To run these QTP tests, we use a batch (.bat) file which starts QTP and runs the tests on a web application through IE (Internet Explorer).

Issue:

When triggered through a bamboo-client, the batch file runs. However, the GUIs of QTP and the business Application Under Test (AUT), i.e. IE are not visible on the screen. Hence, QTP tests cannot identify the AUT GUI objects, resulting in failures.

Surprisingly, same QTP tests run well when I manually run the same batch file by connecting to the same Remote Agent (using a remote connection tool - Microsoft Remote Desktop Connection)

This issue appears to arise only with a 64 - bit Remote Agent. We have found that it works well with 32-bit Remote Agents.

You can find more details related to agent machine, and build plan below. Kindly suggest a suitable solution for the same.

1 answer

This widget could not be displayed.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

169 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you