Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

TLS handshake issue

Our bamboo server has two ports for https connection which are 443 and 8443. I used curl to test the connection. 8443 works as expected, the tls connection can be established but not 443. the tls handshake failed at the server hello stage.

 

when I send the request through port 443. I have this error. 

* ALPN, offering h2
* ALPN, offering http/1.1
* Cipher selection: some string
* successfully set certificate verify locations:
* CAfile: path to pem file
CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number
* stopped the pause stream!
* Closing connection 0
curl: (35) error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number

 

any ideas for troubleshooting? thanks in advance!

 

1 answer

0 votes
Daniel Eads Atlassian Team Aug 24, 2019

Hey there!

This is likely a misconfiguration at your reverse proxy. You've got http/2 enabled so I'm guessing it's either nginx or Apache. Would you be able to post the configuration for the reverse proxy? Blank out your server name and certificates for sure but it would be helpful to see what cyphers you've got enabled.

Given the test against 8443 went ok though, looks like you've got Bamboo configured correctly! I'm hoping we can get that reverse proxy sorted out for you :)

Cheers,
Daniel

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

223 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you