I have a plan that checks out code from Team Foundation Server (Disclaimer: I'm not too familiar with TFS). VCS checkout task errors out with TF10156 exception. See for more information.
I can't really change the host name, it's along the lines of "bamboo-asdf.intranet.developmentlab.acme.org". The actual hostname with subnet is 35 characters long (again, I don't have control over how the servers are named).
Is there a 32 character limit for server names for this plugin or TFS? Any way to force Bamboo or this plugin to use a shorter alias (e.g. bamboo-asdf in the example above) without the subnet? Aliases without the subnet do get resolved on our systems.
Update: adding the TF10131 error log: