Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Run maven task Edited

Hi, i am trying to add a maven task to one of our project but it shows following error

 

"This job can not be built.

No agents meet this job's requirements."

1 answer

1 accepted

0 votes
Answer accepted

Hello @Clarizza Campos Ramirez,


This happens because Bamboo is not finding an agent with the right capabilities available for one or more jobs in this plan.

I would try to follow these steps to diagnose the issue:

  1. Check the requirements tab of each job in the plan affected (Plan configuration >> (JOB) >> Requirements).
    This will allow you to see what agents are capable to build each job. You need to have agents capable of building all the jobs in your plan.
  2. Check the agent matrix (Admin >> Agents >> Agent Matrix).
    Select the plan you want to investigate and the matrix will show what agents are not able to build the jobs of your plan and why (you will need to hover the mouse over the red boxes to see the message).

Once you understand what is the limitation you are facing, you may need to:

  • adjust the requirements in your plan.
  • adjust the capabilities of the agent(s).
  • adjust the dedication of the agent(s).

Please let me know if that will helped you to find out the issue.

HI @Daniel Santos i look into details you mentioned and my error was due we have an invalid JDK installation, i just change that and everything works good.

 

Thanks.

Like Daniel Santos likes this

I'm glad you could find it. =]
Have a good one!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center - Early Access Program

G’day Bamboo customers, The wait is almost over! We are in the final stages of work on the first release of Bamboo Data Center, our self-managed enterprise offering of Bamboo. This Data Center offe...

1,008 views 0 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you