Repository 403

I'm failing at the first hurdle with a new install of Bamboo.

I have a Atlassian Stash server running in EC2.  I am trying to add one of the project repo's to my fresh Bamboo (hosted) install, but when the build runs, I get:

<project> : Plan 'COOP-BUIL' could not be started. Exception: java.lang.RuntimeException: com.atlassian.bamboo.repository.RepositoryException: com.atlassian.bamboo.plugins.git.GitCommandException: command /usr/bin/git ls-remote http://<user>:<scm host>/scm/cop/source.git failed with code 128. Working directory was [.]., stderr:
[error: The requested URL returned error: 403 while accessinghttp://<user>:********@<scm host>/scm/cop/source.git/info/refs?service=git-upload-pack, fatal: HTTP request failed]

I have:

  • Double checked user credentials
  • Ensured that the user has read/write access
  • Cloned the repo from another server using that user

Also, when I click "view error log" I get what seems to be a binary file (see screenshot).

Screen Shot 2015-02-22 at 11.14.14.png

I'm moving away from our Jenkins CI server to Bamboo because I hoped it would be easier.  But doesn't seem to be at the moment.

Any help gratefully received.

 

 

2 answers

I've also set public access to the repo to check to see if the problem is because of credentials and I get the same error.

0 vote

More about error log problem here: https://answers.atlassian.com/questions/12159050.

About repository - do you use local, remote or elastic agent? Also what operating system is server and agent using?

There are two moments when Bamboo needs access to repository. On server for change detection and on agent for actual build. Seeing actual stack trace with error would help diagnosing what's wrong.

One thing you could try - accessing some public git repository (like on github) just to see if that works.

 

Oh I missed 'hosted'. So you must use elastic agent then. Can your agent and server both connect to your Stash server? You can also ask support for help. They have access to server instance so may be able to help you more.

Hi Peter Thanks for your email. I've worked it out. It seems Bamboo can't connect to a Git repo via HTTP on any other port except 80 or 443. Stash by default runs on 7990, so i've setup a reverse proxy to get it to work on 80. I kind of feel I should have spotted this earlier, but hopefully Atlassian can update their documentation on this. Thanks for your help though.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,818 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you