Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,751
Community Members
 
Community Events
176
Community Groups

Remote triggers from Git, to Bamboo working - not allowed, even when in allowed list

We are have having trouble getting remote triggers from Git, to Bamboo working.

 

The message LOGGED IS:

2016-02-19 04:42:21,952 INFO [http-bio-8085-exec-287] [TriggerRemoteBuild] Build request for plan "PLAYGROUND - Deploy using Curl To Strategic BAMS Artifactory (runs but artifact does not appear)" originated from unknown,10.52.132.2 which is not an allowed address (one of[, 10.52.132.2]).

Bamboo version is 5.9.4 build 5919 - 15 Aug 15

 

This is of course odd, as the IP address is in the list of allowed addresses. Can I get this exact version of source code of this class and surounding classes? Or could someone suggest other methods of resolving this.

 

many thanks

 

Dwane

 

 

 

 

 

 

 

 

 

2 answers

1 accepted

0 votes
Answer accepted

It seems to me that your request comes from through a proxy with "unknown" origin. Since "unknown" is not host trusted by Bamboo, it will not let the request go through.

If you use proxy for remote triggers both proxy and origin server's IP must be allowed in Bamboo.

We have this issue too, but we don't use a proxy. What else can I try ?

Some more digging gave us the following cause and solution

There was a squid proxy between github and bamboo who's x-forwarded settings were changing the headers in the request to:

X-forwarded-for [unknown]

This proxy could not be changed, so a NEW squid reverse proxy (just for github webhooks) was installed on the bamboo server, which could override this setting, and then the webhooks were successfully

 

 

 

 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events