Remote agent not showing proper system properties

Jesse Zhang August 12, 2020

After I configure my bamboo remote agent with following command:

java -jar atlassian-bamboo-agent-installer-6.9.0.jar http://{bambooserver}/agentServer/

On my bamboo web application, it shows only 317 MB is available, but the machine actually has a lot of unused memory at this moment, the remote agent server is one VM from a VSHPERE Server

Memory showing on server:

top - 22:15:10 up 2 days, 1:22, 2 users, load average: 1.00, 1.00, 1.71
Tasks: 424 total, 2 running, 416 sleeping, 6 stopped, 0 zombie
%Cpu(s): 3.3 us, 0.9 sy, 0.0 ni, 95.8 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
MiB Mem : 128929.3 total, 66185.5 free, 2014.6 used, 60729.2 buff/cache
MiB Swap: 8192.0 total, 8192.0 free, 0.0 used. 125884.6 avail Mem

Memory showing on bamboo:

Wednesday, 12 Aug 2020
System Time22:08:08
Up Time4 hours, 44 minutes, 46 seconds (since Wed Aug 12 10:24:07 PDT 2020)
Usernameroot
User TimezoneEtc/UTC
User LocaleEnglish (United States)
System EncodingUTF-8
Operating SystemLinux 5.4.0-42-generic
Operating System Architectureamd64
Available Processors24
Network
Host Nameneobuild
IP Address127.0.1.1
Memory Statistics
Total Memory317 MB
Free Memory231 MB
Used Memory85 MB
Bamboo Paths
Current running directory/root/bamboo-agent-home/bin
Build working directory/root/bamboo-agent-home/xml-data/build-dir
Bamboo Home/root/bamboo-agent-home
Temporary directory/tmp
User home/root

1 answer

1 vote
Sergey Podobry _Stellarity Software_
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 13, 2020

Bamboo reports memory statistics for a JAVA virtual machine and not for your entire OS.  If you need to increase JAVA memory take a look at: OutOfMemory Errors in Bamboo server or in remote agent

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events