Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,330
Community Members
 
Community Events
168
Community Groups

Read time out error when attempting to send from Bamboo on EC2 using Amazon SES

Hi everyone,

I'm facing an issue, when I try to configure the mail server to use for notifications, and I test the connection,  I get a read time out.

The smtp server is an AWS service and there is no limitations, so I guess I'm missing some configuration in Bamboo's side.

I also followed the instructions in this url:

https://confluence.atlassian.com/bamkb/read-time-out-error-when-attempting-to-send-from-bamboo-on-ec2-using-amazon-ses-867032002.html\\


But the problem is still the same.

Thanks in advance

1 answer

1 accepted

1 vote
Answer accepted
thePair Atlassian Team Nov 01, 2018

Hello Jorge! How's everything?

 

By reading at your description and also reading that you've tried the step in the "read timeout error" from the Bamboo Documentation, let me check on a few things:

- I suppose you're using the port 465 to perform the connection, correct?
- Are you checking the Use TLS option?

 

I am asking these, firstly because all SMTP connections established to ses require TLS.

And second, because while I was doing my testing, configuring TLS + 465 gave me the exact same error. 
That said, I would request you to change the port from 465 to either 587, 25 or 5587.

 

Amazon's article referenced here states that:
"To set up a STARTTLS connection, the SMTP client connects to the Amazon SES SMTP endpoint on port 25, 587, or 2587..." and 465 connections although opened are for "TLS Wrapper" connections and "TLS Wrapper is an older protocol, but many clients still support it."

With that, I'm assuming using STARTTLS through port 465 may not work.

Let me know if changing the port and setting Use TLS works. Else we check deeper on the subject! :D

Hi Thiago

 

Thank you for your reply. Ye I was using 465 and TLS so I followed your advice and change the port to 25 and now it works!

Thank you so much

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events