Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Powershell script task returns -1 regardless of its contents.

The following inline Powershell script fails:

Write-Host "------------------------------------------------"
Write-Host "Running Set-CheckEnvironmentVariables script... "
Write-Host "------------------------------------------------"

The error message in the logs is:

Failing task since return code of [powershell -ExecutionPolicy bypass -Command C:\Users\svc-psbuild\AppData\Local\Temp\PS-QA-BQ-146-ScriptBuildTask-5169783270089224447.ps1] was -1 while expected 0

Using a file instead of the inline script fails with the same error.

I was running the script manually on the build machine in the above mentioned temporary folder under the same account as for Bamboo Remote Agent and it worked fine.

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events