Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Plan do not execute any task in the job(s)

I created a simple Plan without any repositories and created a job and task. Task is a simple shell script. However, Bamboo (version 6.3.2) is not able to execute the task and fails with a message "# <build number> did not start" and in the error log section the message is "Build was not queued due to error"

 

Bamboo Error Viewer - Atlassian Bamboo

com.atlassian.bamboo.v2.build.queue.BuildPreQueuedActionFailureException: java.lang.NullPointerException
	at com.atlassian.bamboo.v2.build.queue.BuildQueueManagerImpl.fireCustomPreBuildQueuedActions(BuildQueueManagerImpl

2 answers

HI @Chandra Khandavalli,

Can you attach the screenshot of the configuration what you have configured in Job and which task you have added to it.

If possible please share some logs.

Thanks for the sharing.

What executable is using for building this task?

I am new user to the Bamboo. I did not associate or link any executable to the job/task. I simply created a plan with task type script with inline script. The script simply echoes text to a file. When I run the plan, I receive "Build was not queued due to error".

Is it necessary to associate this task to an executable? and how can it be done?

Our Bamboo is installed on Redhat Linux 6.9

I don't think so here Environment is  an issue, Below are some of the questions related to Script task have look at them may be they will you to resolve this.

https://community.atlassian.com/t5/Bamboo-questions/Making-a-Bamboo-Script-execute-using-bin-bash/qaq-p/205364

https://community.atlassian.com/t5/Bamboo-questions/Script-task-in-Bamboo/qaq-p/79998

Thanks for the support; unfortunately those two links are not related to my specific case.

In my case, I think bamboo is not able to initiate and/or start the task.  It is failing before it can start the task and immaterial of what task I add I get the same error "Build was not queued due to error"

Actually I was working on bamboo from last two yrs but I haven't get this error so unfortunately I'm unable to help you on this... anyway you can contact to atlassian support they will definately provide you the solution.

No problem, thanks either way, I will work with support team

0 votes

Try to disable plugin from Zephyr, it should start working

You nailed it down correctly, thanks a lot!!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

190 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you