PHP Unit Test Plan Failing

Hi,

I am creating plan php unit test task. It always getting failed with following error on logs

unrecognized option --log-xml

I have given all parameters except environment variables. Is it mandatory ? I dont have idea about it. Pulling source from repository working successfully.  Can you clarify? 

1 answer

0 votes

Hi Ashwin,

 

This issue looks very similar to another question here in the Community. 

bamboo-build-failing-for-ANT


What is the path to your phpunit capability?

Sorry to reply very late. phpunit located in /usr/local/bin/phpunit

I have fixed it. I have installed codecoverage, xdebug.

Now getting this error 

No whitelist configured, no code coverage will be generated

Where should I add whitelist settings

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Statuspage

How do your teams prepare for really high (planned) traffic days like Cyber Monday?

Hi there! Shannon from Statuspage here.  👋  With Cyber Monday quickly approaching, we're looking to hear from Atlassian customers – specifically from teams who touch incident response li...

33 views 0 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you