Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Need help to resolve Vulnerabilities Edited

Hi Team,

I found one critical Vulnerabilities (97610 - Apache Struts 2.3.5 - 2.3.31 / 2.5.x < Jakarta Multipart Parser RCE) in bamboo application. We tried to download struts2-core-2.5.20 .jar from apache strut site but its not working, even I tried from maven repository but no luck. So need help from this community to resolve my issue.

Application not started with struts2-core-2.5.20.jar file so I have to roll back with old file again to run application properly.


Bamboo : version build 51314

File Location : /opt/atlassian/bamboo/atlassian-bamboo/WEB-INF/lib

File Name : struts2-core-2.5.1-atlassian-10.jar

Need greater version than 2.5.1



1 answer

0 votes


your version is over EOL so I think you have only two options.

  1. Recommended - Upgrade to some newer version to minimal 6.2.5+, because till previous version is also CVE-2017-14589 which is really critical (from my experience someone mining on Bamboo by this vulnereability of Struts
  2. Risk - Try solve it with another version, but as you know it's not easy or impossible.

Can you make upgrade?

HI Petr,

Thanks for quick reply

I need to check if i can upgrade.




Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

250 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you