Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,993
Community Members
 
Community Events
168
Community Groups

Missing "Enable remote agents" Bamboo Docker

Edited

Hi

 

i did following steps :

$> docker network create bamboo
$> docker run -v bambooVolume:/var/atlassian/application-data/bamboo --name bamboo-server --network bamboo --hostname bamboo-server --init -d -p 8085:8085 atlassian/bamboo-server
$> docker run -v bambooAgentVolume:/home/bamboo/bamboo-agent-home --name bamboo-agent --network bamboo --hostname bamboo-agent --init -d atlassian/bamboo-agent-base http://bamboo-server:8085

 

then i added the bridge network to the bamboo-server

docker network connect bridge bamboo-server

 

i did this step to get access to my docker postgres.

 

After installation with custom postgres-db i navigate into Settings -> Overview -> Agents

 

But there are no remote agent to run my docker build tasks or any other option to enable remote agents, what did i wrong ?

 

kind regards

 

 

 

1 answer

1 vote

Hi @Tarek Liedtke

You will need to check the agent logs to really know what is the issue here, but my first guess is that your remote agent is not able to resolve the bamboo-server name.

This is one of the multiple ways to check the agent logs:

docker logs bamboo-agent

If you confirm the error about the name resolution, you will need to add the extra option in your agent container creation.

--link=bamboo-server

Then check the logs again, to make sure you are moving forward.

Please let us know your findings.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events