Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

MSBuild PreBuild event failing to copy file

We have a few projects in our VS 2019 Solution that take their config files from other projects and then perform various config transforms on them.

In the PreBuild event I have the following,

xcopy "$(SolutionDir)$(TargetName)\web.config" "$(ProjectDir)" /Y /F

When Bamboo runs the MSBuild command it fails with,

error MSB3073: The command "xcopy "..\Project1\web.config" "D:\bamboo\build-dir\50954242\WS-PROD2-COMPILERELEASE\SolutionFolder\Project2\" /Y /F" exited with code 4. 

If I copy the command from the error message and execute it at a command prompt it completes successfully.

 

Hoping someone has some suggestions on resolving this issue.

 

Cheers

Phil

 

2 answers

1 accepted

1 vote
Answer accepted

Ok, after beating my head around sideways with this, I couldn't getting anything to work from within Bamboo. All the different permutations of "copy" commands worked when executed from the command prompt. They even worked when I ran MSBuild from the command prompt.

Ended up re-wiring this as a BeforeBuild Target in the project file.

<Target Name="BeforeBuild">
<ItemGroup>
<ConfigToBeCopied Include="$(SolutionDir)$(TargetName)\web.config" />
</ItemGroup>
<Copy SourceFiles="@(ConfigToBeCopied)" DestinationFolder="$(ProjectDir)" />
</Target>

With that setup and the PreBuild event removed everything built successfully within Bamboo.

 

Cheers

Phil

Jimmy Seddon Community Leader Oct 02, 2020

Hey Phil,

I'm sorry I wasn't able to help you solve what you were trying to do, but I'm glad you found another way to get the results you were looking for.

-Jimmy

0 votes
Jimmy Seddon Community Leader Oct 01, 2020

Hi @Phil Carter,

Looking up what exit code 4 is, I think it's complaining about the path you are passing to the command.

When a Bamboo agent runs a build plan it puts everything into a working directory and runs command from the root of the working directory, unless you specify a sub-directory in the GUI build plan task editor.

I would make sure that that path you are trying to execute the command from is the same as the directory structure from within the agent working directory.

I hope that helps!

-Jimmy

Thanks for the reply Jimmy

When I run the copy from the command prompt, I'm running it from the Bamboo build directory and it works without any issues.

Jimmy Seddon Community Leader Oct 01, 2020

That's a really weird one.  Looking at some of the solutions posted here:

https://stackoverflow.com/questions/5626557/what-is-going-wrong-when-visual-studio-tells-me-xcopy-exited-with-code-4

One of the solutions is talking about the dependency order where something is trying to write to the directory at the same time that you are trying to copy the files that could cause this type of issue.

I'm pulling at strings here but it might be something to check out?

I hope that helps!

-Jimmy

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.2 is here!

I'm happy to announce that Bamboo 7.2 has been released and it’s overflowing with awesome new features. This will be the last major Server release before the launch of Bamboo DC. Bamboo logs We...

481 views 5 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you