Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,368,408
Community Members
 
Community Events
168
Community Groups

Lost admin user access and admin permissions on Bamboo

We have moved our Bamboo server to a different network and restarted the application. After the restart, all internal databse users (like admin, service accounts) lost access and not able to login. We had LDAP connectivity for this application for sign-on and ldap users are able to login, however there is no admin access even to the users who are supposed to have admin permissions. Can you please help here in regaining the access for internal users (admin) and restoring admin permissions?

We have already tried recovering admin password as mentioned in https://confluence.atlassian.com/bamboo/lockout-recovery-process-952624910.html, however we couldn't login using the recovery credentials as well. We see "Invalid user/password" error on login screen. We are running on Bamboo v5.7.2

We verified "admin" user is present in "users" table in the bamboo database. There are no errors in the catalina.out log.

Any help here is very much appreciated.

1 answer

1 accepted

0 votes
Answer accepted

Hello Neeharika

Looks like that recovery process method is not available in your current bamboo version (5.7.2). 

Maybe this Restoring procces I found on Bamboo 5.0 could work?

http://product-downloads.atlassian.com/software/bamboo/downloads/documentation/BAMBOO-5-1-20130911.pdf

 

Check the page 579 :) hope it helps

Thank you very much for responding @Maik, we found this doc https://community.atlassian.com/t5/Bamboo-questions/How-to-reset-Bamboo-Admin-password-also-set-bamboo-internal/qaq-p/86925 that has the exact same steps that you mentioned and were able to regain admin access (admin/admin). Thanks again for posting this complete guide. :)

However, all internal users (service accounts) needed a password reset to be able to login again. Can you help us understand what could have happened that caused this?

Thanks,

Neeharika

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events