Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Linking bamboo 6.5 with Bitbucket 5.3.1 not working Edited

Hi all

I am struggling with an application link between a Bamboo server and a Bitbucket server.

My setup is like this:

 

I have two servers, one for Bamboo and one for Bitbucket and they are both behind an internal loadbalancer.

I can ssh from one server to the other and they can find each other through the app-link wizard. 

All the redirecting works fine, buut... When i go from bamboo to bitbucket i get an error complaing about oauth mismatch. If i manually edit it, both apps appear as "CONNECTED" in the app link overview:

On bitbuckets applink menu:
Screen Shot 2018-05-29 at 09.17.04.pngOn bamboos applink menu:Screen Shot 2018-05-29 at 09.16.48.png

If i then go into the build server, create a project and then select "Bitbucket Server / Stash" i get the message:
Screen Shot 2018-05-29 at 09.18.57.png

 

Any idea why this isnt working?

 

Thanks

1 answer

1 accepted

0 votes
Answer accepted

HI @Kasper Orbitlab,

It should work if you have configured incoming and outgoing link in between both applications properly.

Try to Edit the Applink in both applications and see which Oauth they are using, try to configure the same Oauth in both applications.

You are right it should work. The problem was the proxy configuration in the bitbucket.properties - now it seems to be working

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center - Early Access Program

G’day Bamboo customers, The wait is almost over! We are in the final stages of work on the first release of Bamboo Data Center, our self-managed enterprise offering of Bamboo. This Data Center offe...

992 views 0 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you