Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,191
Community Members
 
Community Events
176
Community Groups

Linked Repositories Reporting Failed to load data from Bitbucket. 401 Unauthorized

Hi,

We use Bamboo to manage our software deployments and have a number of projects set up. All but one are configured using Linked Repositories and the same saved credentials using RSA keys. These all work perfectly, however it's not possible to change the details on the linked repositories as Bitbucket always gives 401 Unauthorized even though the credentials are correct and the deployments work perfectly.

The part that has me stuck, is there is one project with it's Linked Repository set up to use username and password authentication rather than RSA keys. All I should need to do is change it from Username and Password authentication to SSH Private key and select the saved key. The system will not allow this because of the aforementioned 401 unauthorized issue. I need to change it as it won't deploy anymore since Bitbucket changed the way authentication works. It's not possible to set up a new Linked repository as even giving the correct credentials Bamboo still throws that 401 Unauthorized off the password and won't allow me to select SSH private Key for the authentication.

I tried taking a copy of the database and just changing the underlying data to be correct but this breaks the system and I've reverted it.

Regards,
Nicholas Giafis

1 answer

0 votes
  • The first thing to try is to delete the linked repository which is having issues from Bamboo and then resave it, It will create a fresh SSH Key and store it on the Bitbucket server.
    Post which you can link the new repository on the plan and try to run the plan and see if you get the same error.

 

  • If this is not solving the issue , try to install native GIT capability on the server. The authentication issue might be caused by the lack of native git capability on Bamboo server.
  •  To use native Git instead of jGit, please do the following:

 

 # Install a Git binary on the Bamboo server and any remote agents that will need to use it.

 ** [Git - Installing Git|https://git-scm.com/book/en/v2/Getting-Started-Installing-Git]

 # Define it as a Server Capability at *Bamboo Administration > Overview > Server Capabilities*

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events