LFS Is not a Command

Caused by: com.atlassian.bamboo.plugins.git.GitCommandException: command /usr/local/bin/git lfs logs last failed with code 1.

Working directory was [/Users/user/Documents/Bamboo_Home/xml-data/build-dir/_git-repositories-cache/29f637727e04d71afc3648b2a81336eb9655811a]., stderr:
01-Oct-2017 20:56:23 git: 'lfs' is not a git command. See 'git --help'.

 

This only happens on my mac... My PC has 0 issues. 

 

I've tried installing LFS again.

It says it is.

Pointing everything to the bin directory and the local directory

Funny thing is if I try and do the command manually it pops out the lfs info.

 

Not sure what to do. Thanks in advance

1 answer

0 votes
Bill Carreon Atlassian Team Oct 02, 2017

Hi Timothy,

 

Have you ensured that LFS is initialized for the user running Bamboo? If LFS was installed for only a single user, Bamboo may not have access to run LFS.

 

It may also be helpful to clear Bamboo's local repository cache. This documentation, Git Cache Removal in Bamboo, outlines the steps to do so.

It is installed as root. 

 

I would like to point out that sourcetree works but not bamboo.

 

Tried clearing the logs to no effect either. 

 

Manually running git clone works fine and running "which git" points back to the git I've told bamboo to use. That one is usr/local/bin/git 

 

Not sure what else to do here.

Can you please add Script task with command

git lfs version

and run this plan at your Mac agent. It will show if Git LFS is available for user running Bamboo

Hi Alexey 

 

That appears to have failed!

 

So what's the remedy? 

 

Thanks in advance,

tim 

Maybe the better question is how do I find the user that is running Bamboo on my Mac.....? Or how do I change the user running it?

 

Tim 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

How do your teams prepare for really high (planned) traffic days like Cyber Monday?

Hi there! Shannon from Statuspage here.  👋  With Cyber Monday quickly approaching, we're looking to hear from Atlassian customers – specifically from teams who touch incident response li...

61 views 0 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you